16

I've been trying to upload screenshots as an image to ask a question. Has always worked before - at least in other SE sites, and does right now as well. But here I am a teapot - or at least I seem to be saying that I am one.

Why?

Workaround?

(I've tried other images as well, this one was just particularly fun)

note: I was using a 4G connection from my cell phone to my laptop at the time.

enter image description here

update: Currently I can now post images in SciFi SE questions - yay! But I'm still curious what was going on.

  • @amaranth I see :) – uhoh Mar 18 '17 at 7:09
  • 9
    Is it because you're short and stout? – Valorum Mar 18 '17 at 10:05
  • 1
    @Valorum any claims about my shortness and stoutness have been greatly exaggerated - but was I in fact supposed to reply somehow?. – uhoh Mar 18 '17 at 11:07
  • 6
    You have to give a shout. – Valorum Mar 18 '17 at 11:09
  • @Valorum it seems I've now lost the opportunity - but now I can post images again! – uhoh Mar 18 '17 at 11:19
  • 1
    We should just support LaTeX – MissMonicaE Mar 19 '17 at 6:55
  • 3
    @MissMonicaE it's a tradeoff that has to be carefully considered. One of the main objections is the significant increase in page load time (and data) once it is turned on, and I don't think it can be activated on a per-question or as-needed basis. One has to make a case for it, starting with a list of examples of questions/answers in the past where it would have been of significant benefit. Here's an example. – uhoh Mar 19 '17 at 7:07
  • 2
    Related: meta.stackexchange.com/q/185426/236563 – Chenmunka Mar 29 '17 at 7:35
  • @Chenmunka that's quite helpful but slightly worrying about the CSRF violation, thanks! – uhoh Mar 29 '17 at 23:44
3

I got the same error and when I asked about it, I got this response from SE developer Marc Gravell:

We return that error in a few scenarios where we have decided (for various reasons) that we really don't trust the incoming request - usually protection from botnets, hack attempts, attempts from external sites to hijack your account (XSRF failure), etc. I'm not saying that you did any of these things; I suspect something changed on your connection sufficiently to cause a false-positive. Sorry about that. If it is working now, then we're probably fine. Unfortunately, a small number of false-positives is a side-effect of the hostile internet in which we reside :(

In my case, the thing that caused this was probably the fact that I switched WiFi connections either right before or during the image upload. I was also logged out of my account.

  • okay, that settles that. Thanks! – uhoh Nov 28 at 22:30
4

https://en.wikipedia.org/wiki/Hyper_Text_Coffee_Pot_Control_Protocol#Commands_and_replies

418 I'm a teapot
The HTCPCP server is a teapot; the resulting entity body "may be short and stout" (a reference to the song "I'm a Little Teapot"). Demonstrations of this behaviour exist.

Inferring from the specifications (RFC 2324), that code should not be used for proper traffic because it doesn't actually report a status which has any cause to effectively reduce functionality:

This memo provides information for the Internet community. It does not specify an Internet standard of any kind. Distribution of this memo is unlimited.

Purportedly, some HTTP servers will use it as an “easter egg” — albeit a rather unrewarding one. Rotten, perhaps.

I expect that there is nothing you can do to remedy such a situation, excepting were you to experimentally investigate the criteria for why their server chose your connections requests at that time for that error.

  • 2
    But in the scenario I experienced, described in the question, is it I who am the teapot? Is it stackexchange or imgur who is generating this message when I try to upload? I never asked to be a teapot - not that I have anything against being a teapot, but... that wasn't my life plan. :) – uhoh Apr 11 '17 at 4:57
  • Yes, please pardon the repeated re-edits. I should expect that it now answers the question better. – can-ned_food Apr 11 '17 at 19:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .