1

I just tried to link to this page in a comment:

http://en.memory-alpha.org/wiki/Treachery,_Faith_and_the_Great_River_%28episode%29

Unfortunately, the shorthand used in comments sometimes breaks on the comma, and tries to italicize the word "Faith".

Broken example here, with the additional note that it doesn't always break and I don't know why. It worked correctly when I tried to create an example on this question.

Edit now that I look again - I did try to italicize the word "something" at the end of the comment, outside the link. It caught that, so the last underscore is missing. It just didn't actually italicize, presumably because the tag order <a><i></a></i> is invalid.

Short format does not break here under the same conditions.


Per Keen's request:

Broken comment:

[link](http://en.memory-alpha.org/wiki/Treachery,_Faith_and_the_Great_River_%28episode%29) text _this should be italic_

Broken comment


A working comment, which does not have a comma in the link, but does use italics after the link:

[No-comma test](http://en.memory-alpha.org/wiki/Starfleet_commanders) some text _should be italic_

No-comma comment


Same format as the broken comment working correctly in the question text:

Short format [does not break here](http://en.memory-alpha.org/wiki/Treachery,_Faith_and_the_Great_River_%28episode%29) under the _same_ conditions.

Working in question

| |
  • Test example (that for some reason, works..) – Izkata Apr 10 '14 at 23:48
  • link text this should be italic – Izkata Apr 11 '14 at 0:21
  • No-comma test some text should be italic – Izkata Apr 11 '14 at 0:24
  • You should include in the question the full markdown code each of the above comments is using, along with screenshots of the result comment. – user1027 Apr 11 '14 at 15:35
  • test - yes, using "%2C" instead of a comma works. – user8719 Apr 11 '14 at 16:49
  • @Keen Added a couple – Izkata Apr 12 '14 at 1:04

You must log in to answer this question.

Browse other questions tagged .